Degradation to FPS Direct Simulator
Incident Report for Form3 Staging
Postmortem

Form3 were alerted to ongoing latency in successful test payment submissions being updated to a final state on the FPS simulator for Form3 API Gateway customers.

Investigations identified a network configuration issue impacting the status update logic after the payment had been processed.

Form3 engineers identified a fix which was then tested and released, a period of monitoring confirmed no ongoing impact from 21:00 BST on the 27/09/21. We have also confirmed all impacted payments have reached the correct final state.

Form3 continue to proactively monitor the Staging environment to identify service enhancement and prevent impact to payment processing.

Posted Sep 29, 2021 - 08:15 UTC

Resolved
Our FPS Direct service has recovered and normal service has resumed. 

We have confirmed all payments have reached a final state and there has been no further impact since 21:00 BST on the 27/09/21.

The root cause is under investigation for service enhancement and more details will be provided as part of the post mortem in due course.
Posted Sep 28, 2021 - 08:46 UTC
Investigating
We have identified an issue impacting the FPS Direct simulator.

Our engineers are currently investigating and further details will be posted as the investigation progresses
Posted Sep 27, 2021 - 16:54 UTC
This incident affected: Simulators (FPS RT - Direct).