#53902 - Degradation to the FPS Simulator
Incident Report for Form3 Staging
Postmortem

Form3 were alerted to a latency issue when a number of payments were failing to reach their final state on the FPS simulator. It was confirmed that this issue would impact any Form3 API Gateway customers performing testing on the FPS simulator.

Investigations identified a configuration issue impacting the status update logic after a payment had been initially processed.

Form3 engineers identified a fix which was then tested and released, a period of monitoring confirmed no ongoing impact from 13:40 UTC on the 16/08/22. It was also confirmed that the impacted payments have reached their expected final state.

Form3 continue to proactively monitor the Staging environment to identify service enhancement and prevent impact to test payment processing.

Posted Aug 17, 2022 - 13:25 UTC

Resolved
Please note that remediation activity has been completed and we now consider this issue resolved.

Further details will be provided in the postmortem, in due course.
Posted Aug 16, 2022 - 16:34 UTC
Identified
We identified an issue impacting the FPS Simulator due to which some test payments were stuck in a non-final state.

The issue was resolved at 13:40 UTC and after a period of monitoring, our Incident Response Team have confirmed there is no ongoing impact.

Our engineers are currently working on correcting all stuck test payments to their final state.
Posted Aug 16, 2022 - 14:43 UTC
This incident affected: Archived Components (FPS RT - Direct).