Staging Platform Disruption
Incident Report for Form3 Staging
Resolved
Our Staging Environment has recovered and normal service has resumed. 

We will continue to monitor the service to ensure there is no ongoing impact.
Posted Jun 25, 2021 - 09:52 UTC
Investigating
We have identified disruption on the Staging environment impacting some services.

Our engineers are currently investigating and we will provide further details as the investigation continues.
Posted Jun 25, 2021 - 08:53 UTC
This incident affected: Archived Components (FPS RT - Direct, FPS RT - Indirect, Bacs - Direct Participant, SEPA Instant, SEPA CT - Direct, SEPA Direct Debit - Core / B2B, Account Management Services, Confirmation of Payee).