Degradation to FPS Indirect
Incident Report for Form3 Staging
Resolved
This incident has been resolved.
Posted Oct 10, 2019 - 15:48 UTC
Update
We are continuing to investigate this issue.
Posted Oct 10, 2019 - 15:48 UTC
Investigating
We have identified an issue causing stuck payments. We are working closely with our gateway provider to resolve this issue as soon as possible.

Customers may see payment submissions stuck in a "submitted" state

We will post an update when we have more information.
Posted Oct 10, 2019 - 15:40 UTC
This incident affected: Simulators (FPS RT - Indirect).