Notification Service Client Certificate
Incident Report for Form3 Staging
Resolved
New TLS certificates deployed.
Posted Aug 20, 2019 - 15:17 UTC
Identified
We have identified the issue with our client TLS certificates used by the Notification Service.

Customers will see an incorrect Common Name in TLS certificate presented by the staging environment Notification Service.

New certificate is being issued and we will post an update as soon as it is deployed.
Posted Aug 20, 2019 - 14:23 UTC