SEPA Instant Maintenance
Incident Report for Form3 Staging
Resolved
We have confirmed maintenance was completed at 03:00 UTC and following a period of monitoring the service is operating as normal

We have confirmed no payments were impacted by this maintenance and no action is required from customers
Posted Mar 08, 2020 - 03:00 UTC
Investigating
As advised to customers, we are undertaking maintenance of our SEPA Instant service to introduce identified enhancements to the service.
Customers may see a short period of timed out admissions.
Our Incident Response Team are monitoring service performance throughout and we will notify you of any issues seen
Posted Mar 08, 2020 - 02:53 UTC
This incident affected: Simulators (SEPA Instant).